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Set up and analyze VASP calculations with QuantumATK

Downloads & Links

& PDF

The VASP Scripter AddOn
VASP website

VASP files

QuantumWise Platform
Installation Guide
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YouTube

In this tutorial, you will explore how QuantumATK can be used as a graphical interface (GUI) for VASP
calculations. In particular, you will learn how to easily create your structure and generate all the relevant
VASP input files. Also, you will be able to analyze your VASP output files with QuantumATK, and plot the
results.

Note that this tutorial is not a user guide to VASP, nor does QuantumWise provide access to the VASP
code. It is assumed that the user has already obtained and installed VASP website from its official source,
and is familiar with the code.
Contents:

° Setting up the configuration using QuantumATK

e & Analyzing the results

e B 1D Projections of 3D grids

Operations with two or more 3D grids

Visualize 3D grids as density, isosurface, or cut plane

Plot density of states

Plot bandstructure
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o B Analyze MD trajectories
e @ Visualize forces

° Visualize vibrational modes

O Note

Click to read information about all input (#9) and output (@) VASP files.

e #) POSCAR, INCAR, KPOINTS, POTCAR
e ® OUTCAR, CONTCAR, CHGCAR, DOSCAR, EIGENVAL, CHG, PARCHG, ELFCAR

“oRf NE

O Important

#

Read the The VASP Scripter AddOn tutorial in order to:

1. configure the VASP scripter;
2. install the VASP pseudopotential libraries.

Setting up the configuration using QuantumATK

You can use one of the many import, build, and export options as shown in the next pictures:

---------------- ~ Files of type :J

ATK Python (*.py) FHI-aims (*.in)
ATK NotCDF (*.nc) Open Babel (*...)
XYZ (*.xyz) Quantum ESPRESSO (*.in)

IMPORT OPTIONS

CAR (*.car) ASE (*.py)
CASTEP (*.cell *.geon) MBN Explorer (*.in)
CIF (*.cif) VASP (POSCAR* CONTCARX*)
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Builder

Nanoribbon

Nanosheet

Crystallography Open Database

e (LR IEE e Magnetic Tunnel Junction (FeMgO-style)

::rom Pl|l-ng n © Nanotube
rom Clipboard Crystal Builder

New Configuration
From Files

Builder Export Configuration

CIF [*.cif] XYZ [*.xyz] FHI-aims [*.in]
ATK.2008 [*.py] Quantum ESPRESSO [*.in] CASTEP [*.cell]
ASE [*.py] LAMMPS [*.data] Siesta [*.fdf]
ASE/GPAW [*.py] ABINIT [*.in] ASE Trajectory [*.trajl
CAR [*.car] VASP [*] MBN Explorer [*.in]
OpenBabel Supported Format [*]

Note that whatever operation you will perform on your structure you will always be able to export the
configuration to the POSCAR file format by File » Export Configuration. Under the Save as type select
VASP.

e Example: open the Builder ® and Add » From Database > Cassiterite (Sn0O,). Modify the lattice
paramenters to a=4.834 A and c=3.244 A in order to reproduce the results of Godinho et al.. From the
Builder, open Bulk Tools > Lattice Parameters, and keep fractional coordinates fixed and modify the a
and c vectors:
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Builder

P Builders
Cassiterite
¥ BulkTools

Crystal Symmetry Info
Fit Cell

Merge Cells

Repeat

Stretch Cell

Supercell

Swap Axes

vV|iv vV Vv vV v VvV

Wrap

Brillouin Zone Viewer... |

Lattice Parameters..§

Lattice Parameters J

-

Stash B Coordinate Tools
Add

P Device Tools

B Graphics

= P Miscellaneous
Cassiterite
> Selection Tools C

Cheose the lattice type from the dropdown menu.

Lattice type: | Simple Tetragonal =

use fractional coordinates ------------===---=-=---mt Keep fractional ! coordinates constant when changing the lattice
Lattice Parameters

Adjust the lattice parameters of the selected lattice type. Only parameters
relevant for the lattice type can be changed. Lattice parameters can be
exported to the clipboard by right-clicking.

remmeneenneaeed -3 A 4834)a

change the a, c values - v biA b bfe

- CA) 324y ¢/a 0670252

Primitive Vectors

Manipulate the Primitive Vectors directly. This is enly possible if UnitCell was
chosen from the dropdown menu.

x (A) y (&) z(A)
A
B

c

Volume = 75.7109 A*

Use the VASP Scripter to set up the calculation

1. Open the VASP scripter: (from the main QuantumATK window) Custom Scripters > Scripters » VASP
Scripter.

2. Once your structure is ready, drag ‘'n’ drop it from the Stash in the VASP scripter. Then you will see the
structure embedded in the Configuration tab of the VASP scripter:
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[y Configuration

X — 0 VASP Scripter

File  Scripters Windows Help

| ¥ | Path [/home/mySimulations J

Setup Accuracy Electrons lons Properties | Configuration Bandstructure Custom Options

3. Set up you simulation. For a detailed instruction on how the set up you simulation with the VASP
Scripter, refer to the The VASP Scripter AddOn tutorial. In this example, we want to optimize the
geometry of the bulk SnO, structure imported from QuantumATK. So, we choose Setup » Task to
Structural optimization and adjust all the parameters according to your needs.

Setting constraints: If you may want to constrain some specific atoms during the geometry
optimization. You can do that by assigning the tag name constraints to these atoms in the Builder
through the Select » Tags tool. The proper F and T flags will be added to the exported POSCAR.

4. Choose the directory where to save the files and press Save to write the INCAR, POSCAR, KPOINTS and
POTCAR files.

. GEIQM  /home/mySimulations '
_____ The Scripter will write the VASP input files. navigate in your system -
n If any of these files already exist in the 0
directory, you will be asked to confirm if

the existing files should be replaced.

5. Run VASP!
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Analyzing the results

¢ When the calculation is done and you have the VASP output files in the project directory, QuantumATK
will automatically recognize their file format and add them to the LabFloor as shown below:

L S - | VNL (/home/mySimulations/) - Virtual NanoLab
Projects View Tools Windows Help
P t Fil
foleeEs ® LabFloor > Bader Charge Analysis
[Filt Text % Filetypes ¥ Group by | Filename P Computational Chemistry Importer
Builder ¥ Optimization/CHGCAR P Electrode Validator
Name » [l > General Info
@ n(r) B HTST Rates
= imizati > IV-Generator
Scripter \ Optimization Optimization/CHGCAR ;
) 's @ POTCAR P> Projected DOS-Generator
P Thermoelectric Coefficients
M @ roscar
Custom
Seripter @ QUTCAR
- M © oszicar |
& [q 0 KPOINTS ¥ Optimization/OUTCAR
i M © INcAR 3 mplex Bandstructure Analyzer
Erotal
M © conTcAR Crystal Structure Prediction Scripter...
Optimization/OUTCAR & ration Potential Analyze:
et @ CHGCAR p !
M © poscar Effective Bandstructure Analyzer
o M © EIGENVAL F?, Effective mass analyze
™ © LocroT : Ele onon Coupling Analyze
Viewer Optimization/OQUTCAR Ex t
¥ Optimization/CONTCAR Grid Operations
. -
5 < Inelastic Transmission Spectrum Analyzer.
Gas o
Optimization/CONTCAR . B -
al Ba t al
ar E
¥ Optimization/POSCAR e

For example, from CONTCAR you can check the optimized structure by selecting it on the LabFloor and
click on Show in 3D Viewer, or send it directly to the Builder for further modifications. Using CHGCAR you
can inspect the charge density as described below by using different tools such as the 1D Projector, the
Grid Operations and the 3D Viewer tools, which you can find in the right-hand side plugin panel.

1D Projections of 3D grids

By using this tool you will be able to easily plot charge density projections of different types (sum, avarage
or through a point) along the three axes (x,y,z). The window is interactive and by selecting a point on the
graph you will have detailed information in the left-hand side of the window. This tool is pretty handy to
analyze CHGCAR or LOCPOT files:

e select the CHGCAR element in the LabFloor and click the 1D Operations button/bar.
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Optimization/CHGCAR

> V-Generator
> Projected DOS-Generator
B Thermoelectric Coefficients

D Projector...
s,

Crystal Structure Predict

.

X - O 1D Projector - Optimization/CHGCAR
Projection Properties Projection Plot
Grid | 0: Optimization/CHGCAR - ElectronDensity
Axis A B OF 10
Projection type Sum * Average Through point
— 0: B_average
08 —— 0: C_average
Spin projection Sum
| &
H i
Add line Show Preview Removeline |i Clear plot =
: »
Line Info &
Name Value
Source J
Type W
Projection axis
Point coordinates %
Projection type H
Spin
Line
Sum
Y
X
Up Activeline: [[0: C_avey
Down
RealUpDown

ImagUpDown

¢ |f you have performed a potential simulation you can check the Local Potential property in the VASP
Scripter (VASP keyword LVTOT = .TRUE.), the LOCPOT file is written by VASP and it will appear in the
LabFloor. You can analyze the content of this file with the 1D Projector or plot an isosurface or a plane
cut in the Viewer. The figure below show the projection of the local potential along the C axis of a 2L-
MgO/Fe(100) system. You can see that the dipole correction in the middle of the vacuum region has
been applied.
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g Optimization/LOCPOT

1D Projector - LOCPOT

Projection properties Projection Plot
Grid 0: LOCPOT - EffectivePotential 2 |
Axis A B ©c 0.01
Projection type O Sum © Average Through point — 0: C_average
Projection point (fr: onal ¢ 0.005
0.000
Spin projection Up &
Add line | (] Show Preview Remove line | clearplot | 5 g0
Line Info v:
= -0.010
Name Value
- Source 0: LOCPOT - EffectivePotential
Type EffectivePotential —-0.015
i~ Projectionaxis  C
B Point coordinates
Abcissa 0.62827 ~0.020
Ordinate 0.0043974 eV/Ang**3
Projection type  Average
Spin Up e
Line 0: C_average D02 0.2
Active line: |0:C_ave $

Operations with two or more 3D grids

0.4 0.6 0.8 10

This tool allows you to perform any kind of arithmetic operation with two or more CHGCAR files (or any
other 3D grid). Just select the CHGCAR files from the LabFloor (by holding down Ctrl) and click on Grid
Operations. A new window will open. Here you can write the arithmetic expression in the f(x) field (+, -, x
and + are allowed). A preview of the result is also showed. You can save the resulting grid in a NetCDF file
for more detailed analysis (e.g. in the 1D projetor, or the 3D Viewer, see below). For example, this can be
very useful to analyze the charge density difference of a system with and without a defect or before and
after adsorption of a molecule/cluster on a surface and so on.
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89) Optimization/CHGCAR

Export...

Grid Operations.. > | (A e,

Grid Operations

B R

x = O Grid Operations - 2 items
Grids Isosurface | View
f(x)= | B1-A1 How-To
+/ Validate units
bt
Alias Grid Type Unit Grid points | Spintype  Spin
AL CHGCAR ElectronDensity 1/Ang**3 (48,48,64) unpolarized Sum
B1 CHGCAR ElectronDensity 1/Ang**3 (48,48,64) unpolarized Sum

X — O Help

Grid arithmetics

Usage

Write an arithmetic expression for the grids, using the aliases in the
table.

The resulting grid can be shown in the 3D widget or saved to a file.
The currently supported operations are:

« Addition (+)

* Subtraction ()

* Multiplication (*)
* Division (/)

Notes

Save new_grid.nc
The dimensions of the grids must be the same.

The units of the grids in the expression must be consistent. This can Text Representation...
be disabled by unchecking the "Validate units” checkbox.

Example
fix) = (A1+82) * C3 /D1

Visualize 3D grids as density, isosurface, or cut plane

This tool that allows you to display 3D grid data, such as the real-space charge density from CHGCAR, as
isosurfaces or contour plots. Select the object from the LabFloor, click the Viewer button at the right and
choose to plot an isosurface, a density or a plane cut. If your calculation is spin-polarized you will be able
to plot the total charge density (T +1), the spin density difference (1 -{) or only the spin-up (1) or spin-
down ({) density.
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89) Optimization/CHGCAR

Text Representation...

Plot Type

€ plane

> Camens
> Loaal structure

» Molecular Dynamics
> Select Close Neighbors
> Select by Bond Length
B Select by Element

Properties

Rotation Animator.

You can Drag and Drop other elements from the LabFloor directly into this window and overlap the
charge density plot with the structure contained in the CONTCAR file or even with the same CHGCAR
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file to show a different plot type:

Click on Properties on the right-hand side of the Viewer window to have full control over all the aspects of
the plot such as isovalue, positions of the cut planes, colors, ... .

Plot density of states
e Step A. Open the VASP Scripter as described above and drag ‘n’ drop the CONTCAR file into it.
e Step B. Now select a self-consistent Static run (SC) from the list of tasks (in Setup tab).

e Step C. Eventually modify other parameters to run a well converged DOS calculation, e.g. increase the
density of k-point sampling and the number of bands.

e Step D. Save the input files and run VASP!

At the end of the run, the DOSCAR file (and all the other output files) will appear on the LabFloor. Select
the DOSCAR object and click on Show 2D Plot to generate the DOS plot.

I2JE3] Optimization/DOSCAR

VASP (PFJDOS Plot...

x = o VASP (P)DOS Plot - Optimization/DOSCAR

Properties

Density of States Projection selector
DOS (V') £
T T T T T T

Atom Indices

Shells
30 [

Configuration POSCAR File

Eilename | Optimization/POSCAR

:: J‘UULMJ' P.Jw:

85 30 25 20 -15 -

5
E (eV) +/ Auto update

Plot bandstructure

e Step A. Once again, open the VASP Scripter and drag ‘n’ drop the CONTCAR file into it.
e Step B. From the list of (Setup tab) task, select Bandstructure.

e Step C. The Bandstructure tab is now active and you can set up the desired path in the Brillouin zone.
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e Step D. Save the input files including the KPOINTS file and run VASP. Remember that in order to run a
band structure calculation with VASP you have to use a preconverged CHGCAR file in the same
directory!

From the LabFloor select the EIGENVAL object and click the Bandstructure analyzer in the plugin panel. A
new interactive window will open. Here you can zoom into a small region of the plot and measure the
band gap, for example.

E Optimization/EIGENVAL

Bandstructure Analyzer - EIGENVAL

Bandstructure

10

,J‘r-\'

Band 14:

E =-6.944897 eV
k =[0.315790, 0.315790, 0.000000]

=20

e E=-7.21353eV
200 +« BV k = [0.31579, 0.31579, 0]

Analyze MD trajectories

You can analyze your VASP molecular dynamics trajectory directly within QuantumATK. The information
are read from the OUTCAR file, when selected the MDTrajectory object will be loaded in the LabFloor.
Select this object and use either the MD analyzer or the Movie Tool plugin to analyze in detail you
simulation.

e Using the MD Analyzer

This tool will allow you to perform a series of analyses to your MD trajectory. See the Reference
Manual for more details about each anlysis.

Angular distribution

Coordination number

e Density profile

Kinetic energy distribution
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e Mean square displacement

e Nearest neighbor

e Neutron scattering

e Partial structure factor

e Radial distribution

e Temperature profile

¢ Velocity autocorrelation

e Velocity distribution

(@)

MolecularDynamics/OUTCAR

Atom Blocks Game...

4 Atom Eater Game...

c’”“i MD Analyzer } ----------------
MD Afatyzer=—

Movie Tool...

Viewer...

Angular Distribution
Coordination Number
Kinetic Energy Distribution
Mass Density Profile

Mean Square Displacement

Nearest Neighbor
Neutron Scattering
Radial Distribution
Temperature Profile
Velocity Autocorrelation
Velocity Distribution
Voidside Distribution

You can perform these analysis for static configurations as well, i.e. with your POSCAR and

X - O M Analyzer - tutd

‘Quantity _~~Radial Distribution

Plot Parameters

Plot style Line
Clearplot
Analysis Parameters
brin 0.0000ps
Emax 0.9960 ps.
{7 650A .
Frarshiion 005A
Element 1 | All
Element 2 | All
---f-=  Load Plot Add Line

Remove Line ﬁ 0 0 -‘— =

= Radial Distribution

B@av

CONTCAR configurations.

e Using the Movie Tool

With this tool you can visualize all frames you MD trajectory. An interactive plot reporting energies and
temperatures is showed on the left side.
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O

MolecularDynamics/OUTCAR

Atom Blocks Game...
Atom Eater Game...

CW“{ Movie Tool } ----------------

MD A

.
7
Movie Tool... /

Viewer...

Curves ¥ Time unit | picosecond 5
10 - -
—  Equ (eV)
8F —  Ea(l0eV)
—  Eiota (10eV)
6 P
T(10°K)
4
g
4 &
)
4]
=
-4
— =
-6 L L L L
0.0 0.2 0.4 0.6 0.8 10
Time (ps)

OO ++ BEV il LR

You can select any frame and use tha arrow on the bottom-right corner to export the
corresponding configuration to the Builder or to the Scripter for further investigation.

Visualize vibrational modes

Select the VibrationalMode object present in your OUTCAR file and use the Vibrational Visualizer plugin to
select a specific mode and visualize it in a new window. Here, you can select the mode, the number of
repetitions for your structure, the visualization option, and other convenient parameters.

TN

v

y
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Physical settings
Repeat (n,)
Repeat (n.)
Repeat (n.)
Mode

Temperature (K)

Graphics
Matart (overlay)
Fena (Overlay)
Mumber of images

Mode properties

Energy
Wavenumber
Visualization

Movie 5

Visualize forces

If present in your OUTCAR file, forces can be visualized as arrows in the Viewer.

25

16.47 meV

132.80 cm™”
Available

25 FPS
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Fi MolecularDynamics/OUTCAR

Crystal Structur

EX
{ Viewer } ................
Teterep

Viewer... /

S-S

- 2]
Camera
Local structure
Molecular Dynamics
Select Close Neighbors
Select by Bond Length

Select by Element

vyvvwvvivy

Select by Expression

Depth Fade..

Forces.

Properties...
Rotation Animator..

LI

Q@ Previous Next ©
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