No Module Named ipy_user_conf

If you enter QuantumATK in interactive mode (i.e., if you just type “atkpython” on the command line), you may be greeted with a rather lengthy message, asking you to “upgrade”:

ImportError        Traceback (most recent call last)
/opt/QuantumWise/atk-10.8/atkpython/lib/site-packages/IPython/ipmaker.pyc in force_import(modname, force_reload)
     61         reload(sys.modules[modname])
     62     else:
---> 63         __import__(modname)
     64
     65

ImportError: No module named ipy_user_conf
WARNING: /home/username/ipy_user_conf.py does not exist, please run %upgrade!
WARNING: Loading of ipy_user_conf failed.

As the message suggests, enter the command (while you are still in QuantumATK) %upgrade to resolve the issue. The reason is that an existing configuration from a previous version of IPython (either an older QuantumATK or another Python) exists for the user account. Upgrading in this way will not interfere with those older versions.